Etherchannel Summary.
Two types of Port-channel interfaces.
- L2 Port-channel:
- L3 Port-channel.
Modes:
- On : Ports Configured in this mode do not exchange PAgP packets.
- PaGP: Cisco proprietary.
- LACP (802.3ad): Standard.
PaGP groups ports based on:
- Speed
- Duplex mode
- Native VLAN
- VLAN Range
- Trunking Status
- Type.
PaGP Modes:
- Auto: Responds to PaGP packets , but does not start negotiation.
- Desirable: Starts negotiation.
LACP Groups ports based on:
- Speed
- Duplex mode
- Native VLAN
- VLAN Range
- Trunking Status
- Type.
LACP Modes:
- Active: Starts Negotiation and Responds to LACP packets.
- Passive: Responds to LACP packets.
Load Balancing Methods:
- dest-ip: Based on Destination IP address.
- dest-mac: Based on destination-host MAC address of incoming packet.
- src-dest-ip: Load distribution is based on the source and dest host IP address.
- src-dest-mac: Load distribution is based on the source and dest host Mac address.
- src-ip: Based on the source host IP address.
- src-mac: Load based on the source-MAC address of incoming packet
Configuration Samples:
Ex1: L2 Etherchannel With PaGP
SW1:
conf t
int range f0/10 - 18
switchport mode access
switchport access vlan 100
channel-group 5 mode desirable
end
SW2:
conf t
int range f0/10 - 18
switchport mode access
switchport access vlan 100
channel-group 5 mode auto
Example 2: L2 Etherchannel with LACP
SW1:
conf t
int range f0/10 - 18
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 6 mode active
SW2
conf t
int range f0/10 - 18
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 6 mode passive -----> Could be active too.
Ex 3 : L3 Etherchannel with PAgP
SW1:
conf t
int port-channel 10
no switchport
ip add 10.10.10.1 255.255.255.0
exit
int range f0/10 - 18
no switchport
channel-group 10 mode desirable
SW2:
conf t
int port-channel 10
no switchport
ip add 10.10.10.2 255.255.255.0
exit
int range f0/10 - 18
no switchport
channel-group 10 mode auto
Ex 4: L2 Etherchannel with LACP and sr-dest-mac Load balancing.
SW1:
conf t
port-channel load-balance src-dest-mac
int range f0/10 - 18
switchport mode access
switchport access vlan 100
channel-group 11 mode active
SW2:
conf t
int range f0/10 - 18
switchport mode access
switchport access vlan 100
channel-group 11 mode active
Verification Commands:
show etherchannel [channel-group-number] detail
show etherchannel
show etherchannel summary
show etherchannel [channe-group-number] summary
show etherchannel load-balance